iPad system constraints

Our QA Team has found that the iPad 2/iPad Mini is among the lowest performing devices still compatible with Star Trek Timelines, and is known to create a large variety of problems when running the game. Due to its age and discontinued status, there are no plans to attempt to improve performance specifically for this device. As such, we highly recommend upgrading to a newer device if possible.

Have more questions? Submit a request

Comments

Powered by Zendesk